Technical FAQs

Ask a Question

Grouping object shows 'X' in web application

Issue:
Grouping object shows 'X' in web application, Diagrams Appear normal in Vista.

Product line:
PME 7.2 PME 8.X

Cause: 
Diagrams application pool cannot authenticate properly

Resolution:
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
Resolution 1
1. Open IIS manager
2. Expand default web sites , Expand ION ,
3 Click Diagrams
3. On the right hand pane click advanced settings
4. Verify that the location for the diagrams folder is correct . This can be verified by browsing the location indicated. 
  • If the location is wrong , the diagrams location will need to be entered here , EX:  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert for Healthcare\config\diagrams 
5. Verify that the app pool is set to "IONAppPool"

Once these settings are verified you can refresh the diagram web page.

Resolution 2
1. go to C:\Program Files
(x86)\Schneider Electric\Power Monitoring Expert\config\diagrams
2. right click on "images" -> click "Shared With..." -> "Specific People..."
3. Don't change anything on the File Sharing window and just click "Share".  This shares all files in config folder again
4. When prompted, click "Change Settings"
5. Check if the transparent png is displayed on the web
6. If it doesn't work, go to "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\config" and repeat step 2 to 5 on the "diagrams" folder.
7. If it still doesn't work, go to "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert" and repeat step 2 to 5 on the "config" folder.


 
Was this helpful?
What can we do to improve the information ?