Technical FAQs

Ask a Question

How do I setup the Altivar Process Drive to communicate over DeviceNet?

Issue:
How do I setup the Altivar Process Drive to communicate over DeviceNet?

Product Line:
Altivar Process Drive (ATV630, ATV930, ATV650, ATV950, ATV660, ATV960, ATV680, ATV980)

Environment:
All serial numbers for Altivar Process Drive

Cause:
N/A

Resolution:

Setting up DeviceNet on the Drive

EDS Files Assemblies
  • What assemblies are you working with?
  • Drive should be setup for proper assemblies to match PLC
    • Assemblies must be configured using SoMove or in the remote HMI.  
    • Compatible assemblies with the Process Drive are listed below:
      • Communication Scanner Assemblies (Default)
        • 21 and 71 is the default assemblies if you want to change them through the keypad go thru the Main menu: Choose communications enter, then Devicenet enter, Choose conf. Assmebly Now choose and change the assemblies to 100/101
          • (Input and Output Com Scanner Assemblies) (Set up your input and output Scanner tables on the HMI)
          • From the HMI or keypad display Go to main menu: choose communications enter,  Then Communication parameters enter, Modbus SL enter, Modbus Fieldbus enter, scroll down to the bottom of the screen and you will find the Com Scanner Input and Output table
          • Works with IO Profile.
      • ​Other Drive Assemblies 
        • 20: Basic speed control output
        • 21: Extended speed control output
        • 70: Basic speed control input
        • 71: Extended speed control input
          • When using these assemblies you must follow Case 1 or 2  see below the instructions to follow.

        • 103 and 104 - Allen Bradley Assemblies are not available on the Process Drive.
  • Once assemblies are configured correctly in PLC then proceed with drive settings
Basic Settings
- Programming on the Drive
  • Program Communication Settings:
    • [Communication] [Comm Parameters] [DeviceNet]
      • [Address] AdrC (0 to 63)
      • [Bit Rate] bdr  (Auto thru 500kbd)
      • [Data rate used] bdrU (auto thru 500kbd)
      • [Conf. Assembly] CioA (20/70, 21/71 and 100/101)
  • Program Command Settings:
    • [Complete settings] [Command and Reference]
      • ​For command speed from Network, program:
        • [Ref Freq 1 Config] Fr1 - Set to [Com. Module] nEt
        • [Ref 1B switching] rCb - Set to [Ref Freq Channel 1] Fr1
        • [Control Mode] CHCF - Set to [Not separ.] SIM
      • ​Video: Setting an Auto/Manual or Reference Switching on the Altivar Process Drives
  • Powercycle the drive
SoMove
  • Configure drive for correct assemblies
  • Can ONLY be done using Somove
    • [Parameters List] [Fieldbus] [Slot A - DeviceNet]
Communicate with the Drive
  • Using IO Profile
    • Only works with Assemblies 100 and 101
    • [Complete Settings] [Command and Reference] [Control Mode] - Set to IO
    • Command Word - 8501
      Speed Reference Word - 8502 (Hz) and 8602 (rpm)
    • 16 bit word (Bit 0, 1, 2..... 15)
    • Start/Stop must turn on bit 0
      • Write a 1 to start
      • Write a 0 to stop
    • Bit 1 to 15 are assignable like logic inputs
      • Example: To assign a fault reset to bit 2 - [Fault reset] - Set to C302
  • Using CIA402 (DriveCom Profile)
    • Works with all assemblies
    • [Control Mode] to [Not separ.] or [Separate]
    • Command Word - 8501
      Speed Reference Word - 8502 (Hz) and 8602 (rpm)
    • No 16 bit word
    • Start/Stop
      • Sequence of values must be written to the drive
      • 6, 7 and 15
      • Toggle between 7 and 15 to start and stop

Similar FAQs
FA313372: How do I troubleshoot an Altivar Process Drive that would not connect to a DeviceNet network?



 
Was this helpful?
What can we do to improve the information ?