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Why am I unable to add my Combox to Conext Insight?

Issue:
Error when trying to add a Combox to Conext Insight: "The ComBox MAC ID and Serial Number combination seems to be invalid OR this Combox has not gone live yet

Environment:
Adding a newly commissioned Combox to Conext Insight, and the MAC ID and Serial Number are correct.

Resolution:
Verify that the Combox has a connection to the Conext Insight Web Portal.  This would be denoted by a check mark in a green circle in the Web Portal Status line.  If not, verify that the TCP/IP settings are appropriate for the device in question.  The DNS server address should look like a normal network IP address, ie. 192.168.0.1 or something appropriate for the network. After commissioning a Combox, wait at least 40 minutes and possibly up to 24 hours to add it to Conext Insight.

Cause:
Information is not in the setup guide for Conext Insight.  The Combox needs time to initialize itself before it can be recognized by Conext Insight.  
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