Technical FAQs

Ask a Question

Can Powersuite Version 2.4.0 work on Windows 2000, Windows 95, Windows 98, Linux or MAC?

No, The Powersuite V2.4.0 requires a Windows XP Operating System.


CTA-ID : 2032272
Was this helpful?
What can we do to improve the information ?