Technical FAQs

Ask a Question

Will the current version of Power Suite Software work with older ATV58 drives?

Yes, the current version should be able to set any setting in your existing drive.

It will not be possible to use features that are available in the software that are not part of the drive.
For example, one could not assign a logic input to an external fault contact on a drive with version 4.1 firmware. It may show up as an option on Powersuite, but it is not a feature that was available with version 4.1 or older drives.


CTA-ID : 2012548
Was this helpful?
What can we do to improve the information ?